مشکل در اجرای Layoutدر ایکلیپس

0 امتیاز
39 بازدید
سوال شده مهر 19, 1394 توسط android  
برچسب گذاری دوباره مهر 23, 1394 توسط ASHKARAN

با سلام و احترام

استاد زمانی که ایکلیپس رو باز میکنم ویک پروژه میسازم شروع میکنه به لود کردن و ساخت کتابخانه اندروید اما وقتی لود تمام میشه صفحه لایوت باز نمیشه که تصویر گوشی رو نمایش بده . پایین صفحه یک اخطار میده لطفا راهنمایی کنید مشکل از کجاست.

این روهم بگم که پکیج sdk من از API2 تا API 23 هست که کامل ترین sdk هست و فکر نکنم مشکل از sdk باشه

 

مینیمم SDK واسه این پروژه رو گذاشتم API8

Target SDK API 21

MAX SDK API 23

http://uupload.ir/files/2sqt_untitled.png

اینم یه اسکرین شات از صفحه ایکلیپس زمان اخطار

این مطلب را به اشتراک بگذارید

2 پاسخ

0 امتیاز
پاسخ داده شده مهر 19, 1394 توسط ASHKARAN  

با عرض سلام

مشکل از کتابخانه appcompat _v7 شماست

در صورتی که API 19 به بعد رو پاک کنید و Target SDK  رو روی 19 قرار بدید فکر می کنم مشکلتون در حال حاضر رفع میشه.....

در صورتی که می خواین با API LEVEL  بالا کار کنید باید برای رفع ارور appcompat _v7  اقدام فرمایید.

بهتون پیشنهاد می کنم Java 1.8  رو هم نصب بفرمایید.

دارای دیدگاه مهر 19, 1394 توسط android  
من چجوری میتونم مشکل appcompat_v7 رو حل کنم ؟چون ترجیح میدم با API Level  بالا کار کنم
دارای دیدگاه مهر 19, 1394 توسط ASHKARAN  

باید ببینیم دقیقا ارورش از چیه.... بگردید و منبع مشکل رو پیدا کنید.

دارای دیدگاه مهر 20, 1394 توسط android  
با سلام و احترام

من مشکل رو حل کردم.

به این صورت بود که min SDK رو باید میذاشتم روی API 14 یعنی اندروید چهار چون max SDK من API 23 یعنی اندروید 6 هستش قابلیت های اندروید 6 رو اندروید زیر چها نمیتونه ساپورت کنه.(البته فکر میکنم). شاید راه های دیگه ای هم داشته باشه واسه حل این مشکل اما تنها راهی که باعث شد این اخطار بره همین راه بود واسه من
دارای دیدگاه مهر 20, 1394 توسط ASHKARAN  
تبریک میگم

لطفا نظرتون رو به عنوان یک پاسخ ارسال بفرمایید تا به عنوان بهترین پاسخ انتخاب شده و دیگران هم استفاده کنن....
دارای دیدگاه مهر 20, 1394 توسط android  
چشم حتما این کار رو انجام میدم
0 امتیاز
پاسخ داده شده مهر 20, 1394 توسط saeednoshadi  
با سلام و احترام

من مشکل رو حل کردم.

به این صورت بود که min SDK رو باید میذاشتم روی API 14 یعنی اندروید چهار چون max SDK من API 23 یعنی اندروید 6 هستش قابلیت های اندروید 6 رو اندروید زیر چها نمیتونه ساپورت کنه.(البته فکر میکنم). شاید راه های دیگه ای هم داشته باشه واسه حل این مشکل اما تنها راهی که باعث شد این اخطار بره همین راه بود واسه من

719 سوال

671 پاسخ

1,174 دیدگاه

317 کاربر

به خانه برنامه نویسان ایرانی خوش آمدید . سوالتان را به سادگی هرچه تمام تر پرسیده و پاسخ آن را دریافت کنید.
ذکات علم نشر آن است.


لطفا از Android Studio استفاده بفرمایید

این مطلب را به اشتراک بگذارید

ali.ashkaran@gmail
ما .....
  • سعی بر پاسخگویی به سوالات دیگران داریم.
  • به سوال و یا نظر دیگران احترام می گذاریم .
  • این وبسایت را به دیگران معرفی می کنیم.
  • همواره صمیمیت و ادب را رعایت می کنیم.
  • به سوالمان برچسب های مرتبط اضافه می کنیم.
  • در حین طرح سوال فرد خاصی را مخاطب قرار نمی دهیم .
...