نصب ایکلیپس در لینوکس اوبونتو

0 امتیاز
407 بازدید
سوال شده مهر 17, 1394 توسط بی نام  
سلام استاد

من میخوام ایکیلیپس رو هم نصب کنم در لینوکس اما به مشکل خوردم میشه راهنمایی کنید؟

مرسی
این مطلب را به اشتراک بگذارید
دارای دیدگاه مهر 20, 1394 توسط بی نام  
ویرایش شده مهر 23, 1394 توسط ASHKARAN

سلام دیدن این ویدیو تا یه حدی شاید درنصب اکلیپس مفید باشه  

http://www.youtube.com/watch?v=l2ryI2IcQxY

 

1 پاسخ

+1 امتیاز
پاسخ داده شده مهر 22, 1394 توسط Hossein  
ویرایش شده مهر 24, 1394 توسط Hossein
 
بهترین پاسخ

 

سلام دوست عزیز نصب eclipse در اوبنتو با توجه به راهنمایی های استاد اشکاران و کمی جستجو در گوگل بیشتر از نیم ساعت طول نمیکشه  با نام خدا واجازه استاد شروع میکنیم :

(سیستم عامل مورد نظر: ۶۴ بییتی)

دانلود فایل های زیر:

    1. jdk-8u60-linux-x64.tar     =========> http:// oracle.com
    2. adt-bundle-linux-x86_64-20140702 =========> http://pnsurez.blogspot.com/2015/08/adt-bundle- android-developer-tools-adt. Html 
    3. ADT-23.0.6  =========>  http://downloads.puresoftware.org/files/android/ADT/
    4. sysimg_x86-10_r02   =========> http://downloads.puresoftware.org/files/android/system-images/
    5. android-2.2_r03-API-8   =========>  http://downloads.puresoftware.org/files/android/API/

ازسایت های اصلی هم میتونید دانلود کنید

https://developer.android.com/develop/index.html


////////////////////////////////////////////////////////

گام دوم :

نصب کامل جاوا :

 

 

jdk دانلود شده رو به درون پوشه در مسیر Computer/Home/temp  اکسترکت بفرمایید

 

وسپس ترمینال رو باز کرده و بعد از وارد کردن هر دستور کلید enter  رو بزنید.

sudo  su


پسورد تون رو وارد بفرمایید

وسپس دستورات زیر رو:
 

if [ ! -d '/usr/lib/jvm' ]; then mkdir /usr/lib/jvm; fi 
mv /tmp/jdk1.8.0_60 /usr/lib/jvm/

 

 

بعد از این مرحله jdk  از tmp  به computer/ usr/lib/ jvm  منتقل میشود یعنی tmp  خالی میشود حتما چک کنید.

 

اگر چنین بود مجوز وارد کردن دستورات زیر رو دارید در غیر اینصورت دو باره امتحان کنید

        

update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk1.8.0_60/bin/java 1065                          

که در اخر جواب هرکدوم از این دستور ها auto mode رو میبینیم
 

update-alternatives --install /usr/bin/javac javac /usr/lib/jvm/jdk1.8.0_60/bin/javac 1065
update-alternatives --install /usr/bin/jar jar /usr/lib/jvm/jdk1.8.0_60/bin/jar 1065
update-alternatives --install /usr/bin/javaws javaws /usr/lib/jvm/jdk1.8.0_60/bin/javaws 1065
update-alternatives --config java

که در اخر جواب دستور بالا  nothing to configure رو میبینیم

java -version

ورژن جاوای نصب شده نشان داده خواهد شد

///////////////////////////////////////////////

سپس دستور زیر را وارد بفرمایید(os:64 bit)

sudo apt-get install lib32ncurses5 lib32stdc++6 zlib1g:i386 libc6-i386

برای erorr ddms و adb.

///////////////////////////////////////

واگر با erorr sdk manager مواجه شدین که خواهید شد از تولبار بالای اکلیپس گزینه window و سپس preference ,android  را انتخاب کنید

 STEP 3:

در مسیر Home  یک پوشه با نام applications ایجاد کرده و فیل دانلود شده شماره 2 را درون ان extract  بفرمایید و سپس پوشهextract  شده را باز کنید وسپس پوشه eclipse را بازکرده و eclipse  را اجرا بفرمایید

پس از اینکه اکلیپس بالا اومد ازtoolbar  بالا گزینه help و install new software  را انتخاب و در مسیر ان فایل دانلود شده شماره 3 را انتخاب کرده و... ودر پنجره install دکمه add رو بفشارید ود قسمت location ادرس فایل شماره ۳ را وارد کرده وok و سپس در قسمت name ,developer tools  را تیک بزنید و...

 

سپس در مسیر Home/ applications/ sdk  پوشه با نام api-8  ایجاد کرده و فایل شماره 4 رو درون ان extract   بفرمایید.(سعی کنید پوشه ها تودر تو نباشند یعنی محتوای دردسترس تر باشد)

/////////////////////////////////////////////

نصب eclipse تقریبا تمام شد اما  مشکلی که داریم اگر بخواهیم API های بالاتر نصب کنیم ,system image دانلود شده مخصوص API مورد نظر رو نمیشناسه . API های بالا تر از 14نیاز به سیستم ایمیج دارن
نشناختن system image جای سواله اگر دوستان نظرشون رو مطرح کنن خیلی عالی میشه
 

و در ضمن از Synpatic packet manager اوبنتو هم میتونید نصب کنید که در اینصورت داشتن پروکسی الزامی هست.

در ضمن این روش نصب از لحاظ بهینه بودن یا نبودن تایید استاد اشکارن رو می طلبه.

 

دارای دیدگاه مهر 23, 1394 توسط ASHKARAN  
با تشکر از شما

واقعا عالی بود

استفاده کردیم.
دارای دیدگاه مهر 23, 1394 توسط Hossein  
ویرایش شده مهر 23, 1394 توسط Hossein
خواهش میکنم استاد بالاخره شاگرد شما هستیم

فقط یه مشکلی هست اونم اینکه api های بالاتر از ۱۴ سیستم ایمج هاشون توی AVDشناخته نمیشه .چرا؟
دارای دیدگاه مهر 23, 1394 توسط ASHKARAN  
باید دید کدوم image هارو دانلود می کنید....

بعضی از اونها تو یک سری سیستم ها کار نمی کنن....
دارای دیدگاه مهر 23, 1394 توسط Hossein  
ویرایش شده مهر 23, 1394 توسط Hossein
system image  api 19  ---------->armeabi-v7a + android-wear +default

 

https://software.intel.com/en-us/android/articles/android-44-kitkat-x86-emulator-system-image

لطفا یه سری به این ادرس بزنید دوتا سیستم ایمیج هست یکی ۳.۸ GB اونو دانلود کنیم؟
دارای دیدگاه مهر 23, 1394 توسط ASHKARAN  

چرا از SDK Manager  دانلود نمی کنید؟

دارای دیدگاه مهر 23, 1394 توسط Hossein  
نحوه نصب cisco روی ubuntu یه کم مشکله چون از سایت ciscoنمیتونم کانکشن مخصوص linux رو دانلود کنم به دلیل تحریم

یعنی به خاطر پروکسی نمیتونم از sdk دانلود کنم

اگر امکانش هست کلا نحوه نصب رو توضیح بدین
دارای دیدگاه مهر 23, 1394 توسط ASHKARAN  

لطفا در یک سوال مجزا نحوه دانلود از SDK Manager رو مطرح بفرمایید تا دیگران هم استفاده کنند.

721 سوال

671 پاسخ

1,174 دیدگاه

318 کاربر

به خانه برنامه نویسان ایرانی خوش آمدید . سوالتان را به سادگی هرچه تمام تر پرسیده و پاسخ آن را دریافت کنید.
ذکات علم نشر آن است.


لطفا از Android Studio استفاده بفرمایید

این مطلب را به اشتراک بگذارید

ali.ashkaran@gmail
ما .....
  • سعی بر پاسخگویی به سوالات دیگران داریم.
  • به سوال و یا نظر دیگران احترام می گذاریم .
  • این وبسایت را به دیگران معرفی می کنیم.
  • همواره صمیمیت و ادب را رعایت می کنیم.
  • به سوالمان برچسب های مرتبط اضافه می کنیم.
  • در حین طرح سوال فرد خاصی را مخاطب قرار نمی دهیم .
...