برای نسخه 2.2.1 اندروید استدیو باید از فیلتر شکن استفاده کرد؟

0 امتیاز
4,601 بازدید
سوال شده خرداد 9, 1395 توسط nima mirzanjani  
برای نسخه 2.2.1 اندروید استدیو باید از فیلتر شکن استفاده کرد؟ اخه نمیتونم پروژه جدید بسازم میگه سینس کردن کامل نمیشه و ارور میده
این مطلب را به اشتراک بگذارید

3 پاسخ

0 امتیاز
پاسخ داده شده خرداد 9, 1395 توسط nima mirzanjani  
منظورم 2.1.1 بود
0 امتیاز
پاسخ داده شده خرداد 9, 1395 توسط zamani  
سلام

منم این مشکل رو دارم با اندروید 2.1.1

Error:Failed to resolve: junit:junit:4.12
Show in Project Structure dialog

اینجا دو راه گفته شده

http://stackoverflow.com/questions/32519219/error23-17-failed-to-resolve-junitjunit4-12
دارای دیدگاه خرداد 9, 1395 توسط nima mirzanjani  
شما ای کارا رو کردین مشکلتون حل شد؟ ایمبورتم نمیتونم بکنم هیچ بروژه ای رو
دارای دیدگاه خرداد 9, 1395 توسط zamani  

من دو روزه نصب کردم این ورژن رو

دیدم خطا میده از این خط

testCompile 'junit:junit:4.12'

کلا پاکش کردم. مشکل حل شد

منتها الان دوباره برای پروزه  جدید تست زدم همون خطا رو میداد

از این خط کد که گفته بود اضافه کنید استفاده کردم

android {
    [...]
    repositories {
        maven { url 'http://repo1.maven.org/maven2' }
    }
    [...]
}

 

درست شد منتها با فیلتر شکن!

البته دیگه برای پروژه جدید نیازی نبود و بدون خطا بود

بهتره این خط کد رو اضافه کنید .

دارای دیدگاه خرداد 9, 1395 توسط zamani  
مشکل ایمپورت رو منم داشتم منتها از تعداد کاراکتر از من ایراد میگرفت. البته من اسامی طولانی تری رو هم قبلا استفاده کرده بودم ولی این مشکل نیود بعد از نصب ورژن جدید این مشکل پیدا شد.

مسیر ذخیره پروژه و اسمش رو کوتاهتر کردم حل شد

البته نمیدونم خطای شما چیه؟

شاید کتابخونه هایی که استفاده کردید توی اون پروژه رو ایراد میگیره. که نت میخواد و کلا تازگی ها من هر کتابخونه ای بخوام اضافه کنم فیلترشکن میخواد . درصورتی که قبلا این مشکل رو با همین کتابخونه ها نداشتم.

به نظرم بهتره از روش افلاین برای اضافه کردن کتابخونه استفاده بشه.

منم مبتدی هستم به نظرم  از استاد بپرسید شاید راه بهتری رو پیشنهاد بدن.
دارای دیدگاه خرداد 9, 1395 توسط nima mirzanjani  
واسه من نمیزاره \روژه ایجاد کنم اصن به بخش کتابخانه نمیرسم . همون اول که نیو \روجکتو میزنم گریدل و سینس نمیکنه میگه \راکسیتو تنظیم کن

یعنی بخوام \روژه بسازم هم باید به نت وصل باشم و فیلتر شمن استفاده کنم؟

فیلتر شکن و باید تو \راکسیش وارد کنم؟
دارای دیدگاه خرداد 9, 1395 توسط zamani  
ویرایش شده خرداد 9, 1395 توسط zamani
خطایی که دارید رو میشه با عکس بزارید

 

فقط بار اول باید وصل بشید برای ساخت پروژه اونم به خاطر همون خطایی که گفتم . برای دفعات بعد برای ساخت یک پروزه جدید دیگه این خطا رو نباید داشته باشید.

این دوتا لینک رو ببینید دوباره انجام بدید

https://www.jetbrains.com/help/idea/2016.1/importing-an-existing-android-project.html

https://developer.android.com/studio/intro/migrate.html
0 امتیاز
پاسخ داده شده خرداد 9, 1395 توسط android  
سلام

من در حال حاضر دارم با آخرین ورژن اندروید استودیو کار میکنم و هیچ مشکلی هم نداره

اینکه باید کتابخانه ها رو با  چیز شکن دانلود کنید ربطی به اندروید استودیو نداره.کلا واسه اندروید استودیو باید همیشه اینترنت و چیز شکنتون آماده باشه که در مواقع لزوم استفاده کنید.واسه اضافه کردن کتابخانه هم بیشتر کتابخانه ها از ای پی ایران خطا میگیرن و باید از چیز شکن استفاده کنید.

در حال حاضر من فقط واسه کتابخانه ها به نت و چیز شکن احتیاج پیدا میکنم و واسه ساخت پروژه نیازی نیست.البته وقتی تازه اندوید استودیو رو نصب میکنید واسه ساخت اولین پروژه به نت و چیز شکن نیاز دارید

1,006 سوال

839 پاسخ

1,353 دیدگاه

1,315 کاربر

این مطلب را به اشتراک بگذارید

ali.ashkaran@gmail
ما .....
  • سعی بر پاسخگویی به سوالات دیگران داریم.
  • به سوال و یا نظر دیگران احترام می گذاریم .
  • این وبسایت را به دیگران معرفی می کنیم.
  • همواره صمیمیت و ادب را رعایت می کنیم.
  • به سوالمان برچسب های مرتبط اضافه می کنیم.
  • در حین طرح سوال فرد خاصی را مخاطب قرار نمی دهیم .
...